Symptom
When clicking +New Machine to add a new protected machine, the new machine is not added, and instead the user is presented with a blank screen.
Additionally, the following error may be found in Nginx logs :
Cause
This issue is caused by a running Nginx reverse proxy on the Backup Manager system.
By default, Nginx uses Http 1.0 when functioning as a reverse proxy. The "Transfer-Encoding: chunked" response in the R1Soft Backup Manager headers, requires Http 1.1 when no chunked data is sent.
Resolution
Configuring Nginx to use Http 1.1, by adding the lines below, resolves this issue.
proxy_set_header Connection "";
Depending on how Nginx is being used, the configuration change may be added to one of the following conf files:
Global Configuration :
Add the following lines to the http{} section of the primary configuration file : /etc/nginx/nginx.conf
Server Block Configuration (installed from the official Nginx repository) :
Add the following lines to the site config of the virtual host, located here : /etc/nginx/conf.d/
Example:
Server Block Configuration (installed from Debian or Ubuntu Repositories) :
Add the following lines to the site config of the virtual host, located here : /etc/nginx/sites-available/
(configs created in this folder are typically enabled by symlinking to /etc/nginx/sites-enabled/ )
Example:
NOTE: After adding the config lines to the appropriate location for your installation, nginx will need to be reloaded with :
Related Articles
Page: Adding a new protected machine results in a blank screen (Knowledge Base) Labels: blank, nginx, new, machine |
Page: Adding a new protected machine results in a blank screen (Knowledge Base) Labels: blank, nginx, new, machine |
Page: Adding a new protected machine results in a blank screen (Knowledge Base) Labels: blank, nginx, new, machine |
Page: Adding a new protected machine results in a blank screen (Knowledge Base) Labels: blank, nginx, new, machine |